wsl을 설치하고 지우다보면, WSL2에 커널 구성 요소 업데이트가 필요합니다이라는 오류를 만날 수 있습니다. 기존 Ubuntu 삭제 전에는 저런 오류 없이 실행이 잘 되었는데, 삭제 후 다시 설치하니 오류가 발생하네요.

이때, https://aka.ms/wsl2kernel에서 Linux 커널 업데이트 패키지를 다운로드해서 설치하고, 이번에는 ubuntu를 실행하면, 지정된 파일을 찾을 수 없습니다라는 오류가 뜹니다.

이때는 터미널에서 wsl --unregister Ubuntu를 입력해주면 됩니다. 설치한 리눅스가 Ubuntu가 아니면, Ubuntu 대신 사용하시는 리눅스를 넣어주시면 됩니다. 만약, Ubuntu-22.04면 wsl --unregister Ubuntu-22.04를 입력하시면 됩니다.